[BACK]Return to rules CVS log [TXT][DIR] Up to [local] / OpenXM / misc / packages / Linux / Debian-non-free / debian

Annotation of OpenXM/misc/packages/Linux/Debian-non-free/debian/rules, Revision 1.1

1.1     ! takayama    1: #!/usr/bin/make -f
        !             2: # Sample debian/rules that uses debhelper.
        !             3: # GNU copyright 1997 by Joey Hess.
        !             4: #
        !             5: # This version is for a hypothetical package that builds an
        !             6: # architecture-dependant package, as well as an architecture-independent
        !             7: # package.
        !             8:
        !             9: # Uncomment this to turn on verbose mode.
        !            10: #export DH_VERBOSE=1
        !            11:
        !            12: # This is the debhelper compatability version to use.
        !            13: export DH_COMPAT=1
        !            14:
        !            15: # This has to be exported to make some magic below work.
        !            16: export DH_OPTIONS
        !            17:
        !            18: EXECUTABLES=asir
        !            19: SHELL_SCRIPTS=asir
        !            20:
        !            21: INST_PREFIX = `pwd`/debian/tmp/usr/local
        !            22: INST_PREFIX2 = `pwd`/../../debian/tmp/usr/local
        !            23:
        !            24:
        !            25: build: build-stamp
        !            26: build-stamp:
        !            27:        dh_testdir
        !            28:        (export PATH=${PATH}:/usr/lib/jdk1.1/bin ;  cd OpenXM/rc ;\
        !            29:                make install-non-free )
        !            30:        touch build-stamp
        !            31:
        !            32: clean:
        !            33:        dh_testdir
        !            34:        dh_testroot
        !            35:        rm -f build-stamp
        !            36:        -make -C OpenXM/src distclean
        !            37:        dh_clean
        !            38:
        !            39: install: DH_OPTIONS=
        !            40: install: build
        !            41:        dh_testdir
        !            42:        dh_testroot
        !            43:        dh_clean -k
        !            44:        dh_installdirs
        !            45:        mkdir -p ${INST_PREFIX}
        !            46:        mkdir -p ${INST_PREFIX}/bin
        !            47:        (cd OpenXM/rc ;\
        !            48:        make prefix=${INST_PREFIX2} clean-under-prefix ;\
        !            49:        rm -f .done_global ; make prefix=/usr/local all-global-shell-scripts ;\
        !            50:        make prefix=${INST_PREFIX2} install-global-scripts-non-free ;\
        !            51:        make prefix=${INST_PREFIX2} copy-non-free )
        !            52:        -for i in $(EXECUTABLES); do strip ${INST_PREFIX}/OpenXM/bin/$$i ; done
        !            53:        #dh_movefiles
        !            54:
        !            55: # Build architecture-independent files here.
        !            56: # Pass -i to all debhelper commands in this target to reduce clutter.
        !            57: binary-indep: DH_OPTIONS=-i
        !            58: binary-indep: build install
        !            59:        # Need this version of debhelper for DH_OPTIONS to work.
        !            60:        dh_testversion 1.1.17
        !            61:        dh_testdir
        !            62:        dh_testroot
        !            63: #      dh_installdebconf
        !            64:        dh_installdocs
        !            65:        dh_installexamples
        !            66:        dh_installmenu
        !            67: #      dh_installemacsen
        !            68: #      dh_installpam
        !            69: #      dh_installinit
        !            70:        dh_installcron
        !            71: #      dh_installmanpages
        !            72:        dh_installinfo
        !            73: #      dh_undocumented
        !            74:        dh_installchangelogs
        !            75:        dh_link
        !            76:        dh_compress
        !            77:        dh_fixperms
        !            78:        # You may want to make some executables suid here.
        !            79:        dh_suidregister
        !            80:        dh_installdeb
        !            81: #      dh_perl
        !            82:        dh_gencontrol
        !            83:        dh_md5sums
        !            84:        dh_builddeb
        !            85:
        !            86: # Build architecture-dependent files here.
        !            87: # Pass -a to all debhelper commands in this target to reduce clutter.
        !            88: binary-arch: DH_OPTIONS=-a
        !            89: binary-arch: build install
        !            90:        # Need this version of debhelper for DH_OPTIONS to work.
        !            91:        dh_testversion 1.1.17
        !            92:        dh_testdir
        !            93:        dh_testroot
        !            94: #      dh_installdebconf
        !            95:        dh_installdocs
        !            96:        dh_installexamples
        !            97:        dh_installmenu
        !            98: #      dh_installemacsen
        !            99: #      dh_installpam
        !           100: #      dh_installinit
        !           101:        dh_installcron
        !           102: #      dh_installmanpages
        !           103:        dh_installinfo
        !           104: #      dh_undocumented
        !           105:        dh_installchangelogs
        !           106:        dh_strip
        !           107:        dh_link
        !           108:        dh_compress
        !           109:        dh_fixperms
        !           110:        # You may want to make some executables suid here.
        !           111:        dh_suidregister
        !           112:        dh_installdeb
        !           113: #      dh_makeshlibs
        !           114: #      dh_perl
        !           115:        dh_shlibdeps
        !           116:        dh_gencontrol
        !           117:        dh_md5sums
        !           118:        dh_builddeb
        !           119:
        !           120: binary: binary-arch
        !           121: .PHONY: build clean binary-indep binary-arch binary install

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>