[BACK]Return to rules CVS log [TXT][DIR] Up to [local] / OpenXM / misc / packages / Linux / Debian-non-free / debian

File: [local] / OpenXM / misc / packages / Linux / Debian-non-free / debian / rules (download)

Revision 1.1, Sun Jun 20 08:25:06 2004 UTC (20 years ago) by takayama
Branch: MAIN
CVS Tags: R_1_3_1-2, RELEASE_1_3_1_13b, RELEASE_1_2_3_12, KNOPPIX_2006, HEAD, DEB_REL_1_2_3-9

Debian package of OpenXM which is splited into free (BSD, GPL, LGPL) and
non -free (FLL).
Debian-non-free is already tested, but Debian-free has not yet tested.

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper. 
# GNU copyright 1997 by Joey Hess.
#
# This version is for a hypothetical package that builds an
# architecture-dependant package, as well as an architecture-independent
# package.

# Uncomment this to turn on verbose mode. 
#export DH_VERBOSE=1

# This is the debhelper compatability version to use.
export DH_COMPAT=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

EXECUTABLES=asir
SHELL_SCRIPTS=asir

INST_PREFIX = `pwd`/debian/tmp/usr/local
INST_PREFIX2 = `pwd`/../../debian/tmp/usr/local


build: build-stamp
build-stamp:
	dh_testdir
	(export PATH=${PATH}:/usr/lib/jdk1.1/bin ;  cd OpenXM/rc ;\
		make install-non-free )
	touch build-stamp

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp 
	-make -C OpenXM/src distclean
	dh_clean

install: DH_OPTIONS=
install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs
	mkdir -p ${INST_PREFIX}
	mkdir -p ${INST_PREFIX}/bin
	(cd OpenXM/rc ;\
	make prefix=${INST_PREFIX2} clean-under-prefix ;\
	rm -f .done_global ; make prefix=/usr/local all-global-shell-scripts ;\
	make prefix=${INST_PREFIX2} install-global-scripts-non-free ;\
	make prefix=${INST_PREFIX2} copy-non-free )
	-for i in $(EXECUTABLES); do strip ${INST_PREFIX}/OpenXM/bin/$$i ; done
	#dh_movefiles

# Build architecture-independent files here.
# Pass -i to all debhelper commands in this target to reduce clutter.
binary-indep: DH_OPTIONS=-i
binary-indep: build install
	# Need this version of debhelper for DH_OPTIONS to work.
	dh_testversion 1.1.17
	dh_testdir
	dh_testroot
#	dh_installdebconf
	dh_installdocs
	dh_installexamples
	dh_installmenu
#	dh_installemacsen
#	dh_installpam
#	dh_installinit
	dh_installcron
#	dh_installmanpages
	dh_installinfo
#	dh_undocumented
	dh_installchangelogs 
	dh_link
	dh_compress
	dh_fixperms
	# You may want to make some executables suid here.
	dh_suidregister
	dh_installdeb
#	dh_perl
	dh_gencontrol
	dh_md5sums
	dh_builddeb

# Build architecture-dependent files here.
# Pass -a to all debhelper commands in this target to reduce clutter.
binary-arch: DH_OPTIONS=-a
binary-arch: build install
	# Need this version of debhelper for DH_OPTIONS to work.
	dh_testversion 1.1.17
	dh_testdir
	dh_testroot
#	dh_installdebconf
	dh_installdocs
	dh_installexamples
	dh_installmenu
#	dh_installemacsen
#	dh_installpam
#	dh_installinit
	dh_installcron
#	dh_installmanpages
	dh_installinfo
#	dh_undocumented
	dh_installchangelogs 
	dh_strip
	dh_link
	dh_compress
	dh_fixperms
	# You may want to make some executables suid here.
	dh_suidregister
	dh_installdeb
#	dh_makeshlibs
#	dh_perl
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-arch
.PHONY: build clean binary-indep binary-arch binary install