[BACK]Return to rules CVS log [TXT][DIR] Up to [local] / OpenXM / misc / packages / Linux / Debian / debian

Annotation of OpenXM/misc/packages/Linux/Debian/debian/rules, Revision 1.11

1.1       takayama    1: #!/usr/bin/make -f
                      2: # Sample debian/rules that uses debhelper.
                      3: # GNU copyright 1997 by Joey Hess.
                      4: #
                      5: # This version is for a hypothetical package that builds an
                      6: # architecture-dependant package, as well as an architecture-independent
                      7: # package.
                      8:
                      9: # Uncomment this to turn on verbose mode.
                     10: #export DH_VERBOSE=1
                     11:
                     12: # This is the debhelper compatability version to use.
                     13: export DH_COMPAT=1
                     14:
                     15: # This has to be exported to make some magic below work.
                     16: export DH_OPTIONS
                     17:
                     18: # Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.
                     19:
                     20: SHARED_FILES = OpenXM/Copyright OpenXM/doc OpenXM/include OpenXM/man \
                     21:                OpenXM/lib/asir-contrib OpenXM/lib/java-support \
                     22:                OpenXM/lib/k097 OpenXM/lib/math OpenXM/lib/pari \
                     23:                OpenXM/lib/sm1 OpenXM/lib/asir
                     24: BINARY_FILES = OpenXM/bin OpenXM/lib/*.a OpenXM/lib/*.so* OpenXM/lib/*.a.* \
                     25:                OpenXM/rc
                     26: MAN_PAGES    = openxm.1 sm1.1
1.10      takayama   27: EXECUTABLES = gnuplot4ox gnuplot_x11 k0 ox ox_sm1 oxlog oxweave sm1 tigers ox_texmacs
1.1       takayama   28:
1.7       takayama   29: SHELL_SCRIPTS=asir sm1 oxmath oxMathematica ox openxm
1.1       takayama   30:
                     31: INST_PREFIX = `pwd`/debian/tmp/usr/local
                     32:
                     33:
                     34: build: build-stamp
                     35: build-stamp:
                     36:        dh_testdir
                     37:        (export PATH=${PATH}:/usr/lib/jdk1.1/bin ;  cd OpenXM/src ;\
                     38:                make configure ;\
                     39:                make ;\
1.6       takayama   40:                make install ; make install-document ; cd asir-port ; make install ; make clean-for-knoppix)
1.1       takayama   41:        touch build-stamp
                     42:
                     43: clean:
                     44:        dh_testdir
                     45:        dh_testroot
                     46:        rm -f build-stamp
                     47:        make -C OpenXM/src distclean
                     48:        dh_clean
                     49:
                     50: install: DH_OPTIONS=
                     51: install: build
                     52:        dh_testdir
                     53:        dh_testroot
                     54:        dh_clean -k
                     55:        dh_installdirs
                     56:        mkdir -p ${INST_PREFIX}
                     57:        tar cf - ${BINARY_FILES} ${SHARED_FILES}| (cd ${INST_PREFIX} ; tar xf -)
1.2       takayama   58: #      (cd ${INST_PREFIX}/OpenXM/bin ; make clean-for-install)
1.1       takayama   59:        -for i in $(EXECUTABLES); do strip ${INST_PREFIX}/OpenXM/bin/$$i ; done
                     60:        make -C ${INST_PREFIX}/OpenXM/rc repl
                     61:        sed 's/setenv OpenXM_HOME $$HOME/setenv OpenXM_HOME \/usr\/local/' <${INST_PREFIX}/OpenXM/rc/cshrc >${INST_PREFIX}/OpenXM/rc/dot.cshrc
1.3       takayama   62:        sed 's/^OpenXM_HOME=$$HOME/OpenXM_HOME=\/usr\/local/' <${INST_PREFIX}/OpenXM/rc/bashrc >${INST_PREFIX}/OpenXM/rc/dot.bashrc
1.1       takayama   63:        mkdir ${INST_PREFIX}/bin
                     64:        (cd ${INST_PREFIX}/OpenXM/rc ; make openxm ; ./gen-shell-scripts ; cp ${SHELL_SCRIPTS} ../../bin )
1.8       takayama   65:        mkdir -p ${INST_PREFIX}/../../usr/lib/menu
1.9       takayama   66:        mkdir -p ${INST_PREFIX}/../../usr/share/pixmaps
                     67:        cp ${INST_PREFIX}/OpenXM/rc/kde/openxm-binary-knoppix ${INST_PREFIX}/../../usr/lib/menu/openxm-binary
1.11    ! takayama   68:        cp ${INST_PREFIX}/OpenXM/doc/OpenXM-web/hopo_std_color.xpm ${INST_PREFIX}/OpenXM/doc/OpenXM-web/logo-openxm2-color.xpm  ${INST_PREFIX}/../../usr/share/pixmaps
1.1       takayama   69:        #dh_movefiles
                     70:
                     71: # Build architecture-independent files here.
                     72: # Pass -i to all debhelper commands in this target to reduce clutter.
                     73: binary-indep: DH_OPTIONS=-i
                     74: binary-indep: build install
                     75:        # Need this version of debhelper for DH_OPTIONS to work.
                     76:        dh_testversion 1.1.17
                     77:        dh_testdir
                     78:        dh_testroot
                     79: #      dh_installdebconf
                     80:        dh_installdocs
                     81:        dh_installexamples
                     82:        dh_installmenu
                     83: #      dh_installemacsen
                     84: #      dh_installpam
                     85: #      dh_installinit
                     86:        dh_installcron
                     87: #      dh_installmanpages
                     88:        dh_installinfo
                     89: #      dh_undocumented
                     90:        dh_installchangelogs
                     91:        dh_link
                     92:        dh_compress
                     93:        dh_fixperms
                     94:        # You may want to make some executables suid here.
                     95:        dh_suidregister
                     96:        dh_installdeb
                     97: #      dh_perl
                     98:        dh_gencontrol
                     99:        dh_md5sums
                    100:        dh_builddeb
                    101:
                    102: # Build architecture-dependent files here.
                    103: # Pass -a to all debhelper commands in this target to reduce clutter.
                    104: binary-arch: DH_OPTIONS=-a
                    105: binary-arch: build install
                    106:        # Need this version of debhelper for DH_OPTIONS to work.
                    107:        dh_testversion 1.1.17
                    108:        dh_testdir
                    109:        dh_testroot
                    110: #      dh_installdebconf
                    111:        dh_installdocs
                    112:        dh_installexamples
                    113:        dh_installmenu
                    114: #      dh_installemacsen
                    115: #      dh_installpam
                    116: #      dh_installinit
                    117:        dh_installcron
                    118: #      dh_installmanpages
                    119:        dh_installinfo
                    120: #      dh_undocumented
                    121:        dh_installchangelogs
                    122:        dh_strip
                    123:        dh_link
                    124:        dh_compress
                    125:        dh_fixperms
                    126:        # You may want to make some executables suid here.
                    127:        dh_suidregister
                    128:        dh_installdeb
                    129: #      dh_makeshlibs
                    130: #      dh_perl
                    131:        dh_shlibdeps
                    132:        dh_gencontrol
                    133:        dh_md5sums
                    134:        dh_builddeb
                    135:
                    136: binary: binary-indep binary-arch
                    137: .PHONY: build clean binary-indep binary-arch binary install

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>