Annotation of OpenXM/misc/packages/Linux/Debian/debian/rules, Revision 1.12
1.1 takayama 1: #!/usr/bin/make -f
2: # Sample debian/rules that uses debhelper.
3: # GNU copyright 1997 by Joey Hess.
4: #
5: # This version is for a hypothetical package that builds an
6: # architecture-dependant package, as well as an architecture-independent
7: # package.
8:
9: # Uncomment this to turn on verbose mode.
10: #export DH_VERBOSE=1
11:
12: # This is the debhelper compatability version to use.
13: export DH_COMPAT=1
14:
15: # This has to be exported to make some magic below work.
16: export DH_OPTIONS
17:
18: # Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.
19:
20: SHARED_FILES = OpenXM/Copyright OpenXM/doc OpenXM/include OpenXM/man \
21: OpenXM/lib/asir-contrib OpenXM/lib/java-support \
22: OpenXM/lib/k097 OpenXM/lib/math OpenXM/lib/pari \
23: OpenXM/lib/sm1 OpenXM/lib/asir
24: BINARY_FILES = OpenXM/bin OpenXM/lib/*.a OpenXM/lib/*.so* OpenXM/lib/*.a.* \
25: OpenXM/rc
26: MAN_PAGES = openxm.1 sm1.1
1.10 takayama 27: EXECUTABLES = gnuplot4ox gnuplot_x11 k0 ox ox_sm1 oxlog oxweave sm1 tigers ox_texmacs
1.1 takayama 28:
1.7 takayama 29: SHELL_SCRIPTS=asir sm1 oxmath oxMathematica ox openxm
1.1 takayama 30:
31: INST_PREFIX = `pwd`/debian/tmp/usr/local
32:
33:
34: build: build-stamp
35: build-stamp:
36: dh_testdir
37: (export PATH=${PATH}:/usr/lib/jdk1.1/bin ; cd OpenXM/src ;\
38: make configure ;\
39: make ;\
1.6 takayama 40: make install ; make install-document ; cd asir-port ; make install ; make clean-for-knoppix)
1.1 takayama 41: touch build-stamp
42:
43: clean:
44: dh_testdir
45: dh_testroot
46: rm -f build-stamp
47: make -C OpenXM/src distclean
48: dh_clean
49:
50: install: DH_OPTIONS=
51: install: build
52: dh_testdir
53: dh_testroot
54: dh_clean -k
55: dh_installdirs
56: mkdir -p ${INST_PREFIX}
57: tar cf - ${BINARY_FILES} ${SHARED_FILES}| (cd ${INST_PREFIX} ; tar xf -)
1.2 takayama 58: # (cd ${INST_PREFIX}/OpenXM/bin ; make clean-for-install)
1.1 takayama 59: -for i in $(EXECUTABLES); do strip ${INST_PREFIX}/OpenXM/bin/$$i ; done
60: make -C ${INST_PREFIX}/OpenXM/rc repl
61: sed 's/setenv OpenXM_HOME $$HOME/setenv OpenXM_HOME \/usr\/local/' <${INST_PREFIX}/OpenXM/rc/cshrc >${INST_PREFIX}/OpenXM/rc/dot.cshrc
1.3 takayama 62: sed 's/^OpenXM_HOME=$$HOME/OpenXM_HOME=\/usr\/local/' <${INST_PREFIX}/OpenXM/rc/bashrc >${INST_PREFIX}/OpenXM/rc/dot.bashrc
1.1 takayama 63: mkdir ${INST_PREFIX}/bin
64: (cd ${INST_PREFIX}/OpenXM/rc ; make openxm ; ./gen-shell-scripts ; cp ${SHELL_SCRIPTS} ../../bin )
1.12 ! takayama 65: # copying icons for KDE.
1.8 takayama 66: mkdir -p ${INST_PREFIX}/../../usr/lib/menu
1.9 takayama 67: mkdir -p ${INST_PREFIX}/../../usr/share/pixmaps
68: cp ${INST_PREFIX}/OpenXM/rc/kde/openxm-binary-knoppix ${INST_PREFIX}/../../usr/lib/menu/openxm-binary
1.11 takayama 69: cp ${INST_PREFIX}/OpenXM/doc/OpenXM-web/hopo_std_color.xpm ${INST_PREFIX}/OpenXM/doc/OpenXM-web/logo-openxm2-color.xpm ${INST_PREFIX}/../../usr/share/pixmaps
1.12 ! takayama 70: # Do the final cleaning of /usr/local/OpenXM for knoppix package.
! 71: cp delete-files-knoppix.sh ${INST_PREFIX}/../../
! 72: (cd ${INST_PREFIX} ; ./delete-files-knoppix.sh )
! 73: rm -f ${INST_PREFIX}/../../delete-files-knoppix.sh
1.1 takayama 74: #dh_movefiles
75:
76: # Build architecture-independent files here.
77: # Pass -i to all debhelper commands in this target to reduce clutter.
78: binary-indep: DH_OPTIONS=-i
79: binary-indep: build install
80: # Need this version of debhelper for DH_OPTIONS to work.
81: dh_testversion 1.1.17
82: dh_testdir
83: dh_testroot
84: # dh_installdebconf
85: dh_installdocs
86: dh_installexamples
87: dh_installmenu
88: # dh_installemacsen
89: # dh_installpam
90: # dh_installinit
91: dh_installcron
92: # dh_installmanpages
93: dh_installinfo
94: # dh_undocumented
95: dh_installchangelogs
96: dh_link
97: dh_compress
98: dh_fixperms
99: # You may want to make some executables suid here.
100: dh_suidregister
101: dh_installdeb
102: # dh_perl
103: dh_gencontrol
104: dh_md5sums
105: dh_builddeb
106:
107: # Build architecture-dependent files here.
108: # Pass -a to all debhelper commands in this target to reduce clutter.
109: binary-arch: DH_OPTIONS=-a
110: binary-arch: build install
111: # Need this version of debhelper for DH_OPTIONS to work.
112: dh_testversion 1.1.17
113: dh_testdir
114: dh_testroot
115: # dh_installdebconf
116: dh_installdocs
117: dh_installexamples
118: dh_installmenu
119: # dh_installemacsen
120: # dh_installpam
121: # dh_installinit
122: dh_installcron
123: # dh_installmanpages
124: dh_installinfo
125: # dh_undocumented
126: dh_installchangelogs
127: dh_strip
128: dh_link
129: dh_compress
130: dh_fixperms
131: # You may want to make some executables suid here.
132: dh_suidregister
133: dh_installdeb
134: # dh_makeshlibs
135: # dh_perl
136: dh_shlibdeps
137: dh_gencontrol
138: dh_md5sums
139: dh_builddeb
140:
141: binary: binary-indep binary-arch
142: .PHONY: build clean binary-indep binary-arch binary install
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>