Annotation of OpenXM/misc/packages/Linux/Debian/debian/rules, Revision 1.3
1.1 takayama 1: #!/usr/bin/make -f
2: # Sample debian/rules that uses debhelper.
3: # GNU copyright 1997 by Joey Hess.
4: #
5: # This version is for a hypothetical package that builds an
6: # architecture-dependant package, as well as an architecture-independent
7: # package.
8:
9: # Uncomment this to turn on verbose mode.
10: #export DH_VERBOSE=1
11:
12: # This is the debhelper compatability version to use.
13: export DH_COMPAT=1
14:
15: # This has to be exported to make some magic below work.
16: export DH_OPTIONS
17:
18: # Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.
19:
20: SHARED_FILES = OpenXM/Copyright OpenXM/doc OpenXM/include OpenXM/man \
21: OpenXM/lib/asir-contrib OpenXM/lib/java-support \
22: OpenXM/lib/k097 OpenXM/lib/math OpenXM/lib/pari \
23: OpenXM/lib/sm1 OpenXM/lib/asir
24: BINARY_FILES = OpenXM/bin OpenXM/lib/*.a OpenXM/lib/*.so* OpenXM/lib/*.a.* \
25: OpenXM/rc
26: MAN_PAGES = openxm.1 sm1.1
27: EXECUTABLES = gnuplot4ox gnuplot_x11 k0 ox ox_sm1 oxlog oxweave sm1 tigers
28:
29: SHELL_SCRIPTS=asir sm1 oxgp oxmath oxMathematica ox openxm
30:
31: INST_PREFIX = `pwd`/debian/tmp/usr/local
32:
33:
34: build: build-stamp
35: build-stamp:
36: dh_testdir
37: (export PATH=${PATH}:/usr/lib/jdk1.1/bin ; cd OpenXM/src ;\
38: make configure ;\
39: make ;\
40: make install)
41: touch build-stamp
42:
43: clean:
44: dh_testdir
45: dh_testroot
46: rm -f build-stamp
47: make -C OpenXM/src distclean
48: dh_clean
49:
50: install: DH_OPTIONS=
51: install: build
52: dh_testdir
53: dh_testroot
54: dh_clean -k
55: dh_installdirs
56: mkdir -p ${INST_PREFIX}
57: tar cf - ${BINARY_FILES} ${SHARED_FILES}| (cd ${INST_PREFIX} ; tar xf -)
1.2 takayama 58: # (cd ${INST_PREFIX}/OpenXM/bin ; make clean-for-install)
1.1 takayama 59: -for i in $(EXECUTABLES); do strip ${INST_PREFIX}/OpenXM/bin/$$i ; done
60: make -C ${INST_PREFIX}/OpenXM/rc repl
61: sed 's/setenv OpenXM_HOME $$HOME/setenv OpenXM_HOME \/usr\/local/' <${INST_PREFIX}/OpenXM/rc/cshrc >${INST_PREFIX}/OpenXM/rc/dot.cshrc
1.3 ! takayama 62: sed 's/^OpenXM_HOME=$$HOME/OpenXM_HOME=\/usr\/local/' <${INST_PREFIX}/OpenXM/rc/bashrc >${INST_PREFIX}/OpenXM/rc/dot.bashrc
1.1 takayama 63: mkdir ${INST_PREFIX}/bin
64: (cd ${INST_PREFIX}/OpenXM/rc ; make openxm ; ./gen-shell-scripts ; cp ${SHELL_SCRIPTS} ../../bin )
65: #dh_movefiles
66:
67: # Build architecture-independent files here.
68: # Pass -i to all debhelper commands in this target to reduce clutter.
69: binary-indep: DH_OPTIONS=-i
70: binary-indep: build install
71: # Need this version of debhelper for DH_OPTIONS to work.
72: dh_testversion 1.1.17
73: dh_testdir
74: dh_testroot
75: # dh_installdebconf
76: dh_installdocs
77: dh_installexamples
78: dh_installmenu
79: # dh_installemacsen
80: # dh_installpam
81: # dh_installinit
82: dh_installcron
83: # dh_installmanpages
84: dh_installinfo
85: # dh_undocumented
86: dh_installchangelogs
87: dh_link
88: dh_compress
89: dh_fixperms
90: # You may want to make some executables suid here.
91: dh_suidregister
92: dh_installdeb
93: # dh_perl
94: dh_gencontrol
95: dh_md5sums
96: dh_builddeb
97:
98: # Build architecture-dependent files here.
99: # Pass -a to all debhelper commands in this target to reduce clutter.
100: binary-arch: DH_OPTIONS=-a
101: binary-arch: build install
102: # Need this version of debhelper for DH_OPTIONS to work.
103: dh_testversion 1.1.17
104: dh_testdir
105: dh_testroot
106: # dh_installdebconf
107: dh_installdocs
108: dh_installexamples
109: dh_installmenu
110: # dh_installemacsen
111: # dh_installpam
112: # dh_installinit
113: dh_installcron
114: # dh_installmanpages
115: dh_installinfo
116: # dh_undocumented
117: dh_installchangelogs
118: dh_strip
119: dh_link
120: dh_compress
121: dh_fixperms
122: # You may want to make some executables suid here.
123: dh_suidregister
124: dh_installdeb
125: # dh_makeshlibs
126: # dh_perl
127: dh_shlibdeps
128: dh_gencontrol
129: dh_md5sums
130: dh_builddeb
131:
132: binary: binary-indep binary-arch
133: .PHONY: build clean binary-indep binary-arch binary install
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>