Annotation of OpenXM/misc/packages/Linux/Debian2/debian/rules, Revision 1.1
1.1 ! takayama 1: #!/usr/bin/make -f
! 2: # Sample debian/rules that uses debhelper.
! 3: # GNU copyright 1997 by Joey Hess.
! 4: #
! 5: # This version is for a hypothetical package that builds an
! 6: # architecture-dependant package, as well as an architecture-independent
! 7: # package.
! 8:
! 9: # Uncomment this to turn on verbose mode.
! 10: #export DH_VERBOSE=1
! 11:
! 12: # This is the debhelper compatability version to use.
! 13: export DH_COMPAT=1
! 14:
! 15: # This has to be exported to make some magic below work.
! 16: export DH_OPTIONS
! 17:
! 18: # Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.
! 19:
! 20: BINARY_FILES = OpenXM/download/*
! 21:
! 22: INST_PREFIX = "`pwd`/debian/tmp/usr/local"
! 23:
! 24:
! 25: build: build-stamp
! 26: build-stamp:
! 27: dh_testdir
! 28: (cd OpenXM/download ; make install-small )
! 29: touch build-stamp
! 30:
! 31: clean:
! 32: dh_testdir
! 33: dh_testroot
! 34: rm -f build-stamp
! 35: dh_clean
! 36:
! 37: install: DH_OPTIONS=
! 38: install: build
! 39: dh_testdir
! 40: dh_testroot
! 41: dh_clean -k
! 42: dh_installdirs
! 43: mkdir -p ${INST_PREFIX}
! 44: tar cf - --exclude CVS OpenXM | (cd ${INST_PREFIX} ; tar xf -)
! 45: install OpenXM/bin/oxfetch.sh ${INST_PREFIX}/bin
! 46: # copying icons for KDE.
! 47: cp ${OpenXM_HOME}/rc/kde/openxm-binary-knoppix ${INST_PREFIX}/../../usr/lib/menu/openxm-binary
! 48: cp ${OpenXM_HOME}/doc/OpenXM-web/hopo_std_color.xpm ${OpenXM_HOME}/doc/OpenXM-web/logo-openxm2-color.xpm ${INST_PREFIX}/../../usr/share/pixmaps
! 49: #dh_movefiles
! 50:
! 51: # Build architecture-independent files here.
! 52: binary-indep: build install
! 53:
! 54: # Build architecture-dependent files here.
! 55: # Pass -a to all debhelper commands in this target to reduce clutter.
! 56: binary-arch: DH_OPTIONS=-a
! 57: binary-arch: build install
! 58: # Need this version of debhelper for DH_OPTIONS to work.
! 59: dh_testversion 1.1.17
! 60: dh_testdir
! 61: dh_testroot
! 62: # dh_installdebconf
! 63: dh_installdocs
! 64: dh_installexamples
! 65: dh_installmenu
! 66: # dh_installemacsen
! 67: # dh_installpam
! 68: # dh_installinit
! 69: dh_installcron
! 70: # dh_installmanpages
! 71: dh_installinfo
! 72: # dh_undocumented
! 73: dh_installchangelogs
! 74: dh_strip
! 75: dh_link
! 76: dh_compress
! 77: dh_fixperms
! 78: # You may want to make some executables suid here.
! 79: dh_suidregister
! 80: dh_installdeb
! 81: # dh_makeshlibs
! 82: # dh_perl
! 83: dh_shlibdeps
! 84: dh_gencontrol
! 85: dh_md5sums
! 86: dh_builddeb
! 87:
! 88: binary: binary-indep binary-arch
! 89: .PHONY: build clean binary-indep binary-arch binary install
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>