Annotation of OpenXM/misc/packages/Linux/Debian2/debian/rules, Revision 1.4
1.1 takayama 1: #!/usr/bin/make -f
2: # Sample debian/rules that uses debhelper.
3: # GNU copyright 1997 by Joey Hess.
4: #
5: # This version is for a hypothetical package that builds an
6: # architecture-dependant package, as well as an architecture-independent
7: # package.
8:
1.4 ! takayama 9: PACKAGE=$(shell dh_listpackages)
! 10:
1.1 takayama 11: # Uncomment this to turn on verbose mode.
12: #export DH_VERBOSE=1
13:
14: # This is the debhelper compatability version to use.
1.4 ! takayama 15: #export DH_COMPAT=1
1.1 takayama 16:
17: # This has to be exported to make some magic below work.
18: export DH_OPTIONS
19:
20: # Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.
21:
22: BINARY_FILES = OpenXM/download/*
23:
24: INST_PREFIX = "`pwd`/debian/tmp/usr/local"
25:
26:
27: build: build-stamp
28: build-stamp:
29: dh_testdir
30: (cd OpenXM/download ; make install-small )
31: touch build-stamp
32:
33: clean:
34: dh_testdir
35: dh_testroot
36: rm -f build-stamp
1.4 ! takayama 37: dh_clean -d
1.1 takayama 38:
39: install: DH_OPTIONS=
40: install: build
41: dh_testdir
42: dh_testroot
1.4 ! takayama 43: # dh_clean -k
! 44: dh_prep
1.1 takayama 45: dh_installdirs
46: mkdir -p ${INST_PREFIX}
1.4 ! takayama 47: mkdir -p ${INST_PREFIX}/bin
1.1 takayama 48: tar cf - --exclude CVS OpenXM | (cd ${INST_PREFIX} ; tar xf -)
49: install OpenXM/bin/oxfetch.sh ${INST_PREFIX}/bin
50: # copying icons for KDE.
1.4 ! takayama 51: mkdir -p ${INST_PREFIX}/../../usr/lib/menu
! 52: mkdir -p ${INST_PREFIX}/../../usr/share/pixmaps
1.2 takayama 53: cp ${OpenXM_HOME}/rc/kde/openxm-knoppix ${INST_PREFIX}/../../usr/lib/menu/openxm
1.1 takayama 54: cp ${OpenXM_HOME}/doc/OpenXM-web/hopo_std_color.xpm ${OpenXM_HOME}/doc/OpenXM-web/logo-openxm2-color.xpm ${INST_PREFIX}/../../usr/share/pixmaps
55: #dh_movefiles
56:
57: # Build architecture-independent files here.
58: binary-indep: build install
59:
60: # Build architecture-dependent files here.
61: # Pass -a to all debhelper commands in this target to reduce clutter.
62: binary-arch: DH_OPTIONS=-a
63: binary-arch: build install
64: # Need this version of debhelper for DH_OPTIONS to work.
1.3 takayama 65: # dh_testversion 1.1.17
1.1 takayama 66: dh_testdir
67: dh_testroot
1.4 ! takayama 68: dh_installdirs
1.1 takayama 69: dh_installdocs
70: dh_installchangelogs
1.4 ! takayama 71:
! 72: # Copy the packages's files.
! 73: cp -a debian/tmp/usr debian/${PACKAGE}
! 74:
! 75: dh_makeshlibs
1.1 takayama 76: dh_installdeb
1.4 ! takayama 77: -dh_shlibdeps
1.1 takayama 78: dh_gencontrol
79: dh_md5sums
80: dh_builddeb
81:
82: binary: binary-indep binary-arch
83: .PHONY: build clean binary-indep binary-arch binary install
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>