[BACK]Return to rules CVS log [TXT][DIR] Up to [local] / OpenXM / misc / packages / Linux / Debian2 / debian

File: [local] / OpenXM / misc / packages / Linux / Debian2 / debian / rules (download)

Revision 1.3, Fri Feb 12 07:37:33 2016 UTC (8 years, 3 months ago) by takayama
Branch: MAIN
Changes since 1.2: +1 -1 lines

Fixes for Wheeyzy.

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper. 
# GNU copyright 1997 by Joey Hess.
#
# This version is for a hypothetical package that builds an
# architecture-dependant package, as well as an architecture-independent
# package.

# Uncomment this to turn on verbose mode. 
#export DH_VERBOSE=1

# This is the debhelper compatability version to use.
export DH_COMPAT=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

# Variables from top level Makefile (for FreeBSD) of OpenXM. Slightly modified.

BINARY_FILES = OpenXM/download/*

INST_PREFIX = "`pwd`/debian/tmp/usr/local"


build: build-stamp
build-stamp:
	dh_testdir
	(cd OpenXM/download ; make install-small )
	touch build-stamp

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp 
	dh_clean

install: DH_OPTIONS=
install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs
	mkdir -p ${INST_PREFIX}
	tar cf - --exclude CVS OpenXM | (cd ${INST_PREFIX} ; tar xf -)
	install OpenXM/bin/oxfetch.sh ${INST_PREFIX}/bin
# copying icons for KDE.
	cp ${OpenXM_HOME}/rc/kde/openxm-knoppix ${INST_PREFIX}/../../usr/lib/menu/openxm
	cp ${OpenXM_HOME}/doc/OpenXM-web/hopo_std_color.xpm ${OpenXM_HOME}/doc/OpenXM-web/logo-openxm2-color.xpm  ${INST_PREFIX}/../../usr/share/pixmaps
	#dh_movefiles

# Build architecture-independent files here.
binary-indep: build install

# Build architecture-dependent files here.
# Pass -a to all debhelper commands in this target to reduce clutter.
binary-arch: DH_OPTIONS=-a
binary-arch: build install
	# Need this version of debhelper for DH_OPTIONS to work.
#	dh_testversion 1.1.17
	dh_testdir
	dh_testroot
#	dh_installdebconf
	dh_installdocs
	dh_installexamples
	dh_installmenu
#	dh_installemacsen
#	dh_installpam
#	dh_installinit
	dh_installcron
#	dh_installmanpages
	dh_installinfo
#	dh_undocumented
	dh_installchangelogs 
	dh_strip
	dh_link
	dh_compress
	dh_fixperms
	# You may want to make some executables suid here.
	dh_suidregister
	dh_installdeb
#	dh_makeshlibs
#	dh_perl
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install